BCS Tools

Recommendations and limitations for BCS Tools 3.30

Minimum firmware requirements

  • X2 control/X2 marine SC, BoX2 pro SC image 2.0 b775 with CODESYS runtime 3.5.13.30_7
  • X2 extreme SC, BoX2 extreme SC image 2.0 b367 with CODESYS runtime 3.5.13.30_7
  • BCS Nexto firmware 1.8.6.0 for NX3010/NX3020/NX3030
  • BCS Nexto firmware 1.9.2.0 for NX3003/NX3004/NX3005
  • BCS Nexto firmware 1.9.2.0 for XP300/XP315/XP325/XP340
  • GN-9372 with firmware 1.000

Supported hardware devices with BCS Tools Lite license

  • X2 control
  • X2 marine SC
  • X2 extreme SC
  • BoX2 pro SC
  • BoX2 extreme SC
  • PIO GN-9372 (GN-9373 is NOT supported in the current version)
  • Nexto modular (<= BCS-NX3010 without fieldbus expansion)
  • Nexto Xpress (BCS-XP3xx)

Project upgrade from CODESYS to BCS Tools

BCS Tools supports upgrading of projects from CODESYS consisting of targets from Beijer Electronics. Prerequisites of supported hardware can be found in section “Supported hardware devices”.

For more details about project upgrades please refer to the Quick Start Guide (SUEN00404).

Project conversion limitations

Project conversion with Project update function is NOT possible between the following devices (manual copy/paste or PLCopen XML import/export can be used):

  • GN-9372 -> BCS-XP3xx
  • GN-9372 -> BCS-NX3xx

 

  • X2/BoX2 -> BCS-XP3xx
  • X2/BoX2 -> BCS-NX3xx

 

  • BCS-XP3xx -> BCS-NX3xxx
  • BCS-XP3xx -> X2/BoX2
  • BCS-XP3xx -> GN-9372

 

  • BCS-NX3xxx -> BCS-XP3xx
  • BCS-NX3xxx -> X2/BoX2
  • BCS-NX3xxx -> GN-9372